Get in touch
Back
Maintenance

Security Update Reboot

Completed 8 Jan at 12:08am CST.

WordPress 02 Primary
Completed

Maintenance completed

Posted 8 Jan at 12:08am CST.
Started

Standard security reboot. Expected downtime is 2-3 minutes.

Posted 8 Jan at 12:00am CST.